about summary refs log tree commit diff stats
path: root/hm/soispha/conf/firefox/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-10-21 00:04:35 +0200
committerSoispha <soispha@vhack.eu>2023-10-21 00:04:35 +0200
commit7f158fa65e4b563a22ef9dbf67c7d3a9d34f7b11 (patch)
tree52878e96d2f35c2d36707dba80ba076205d78add /hm/soispha/conf/firefox/default.nix
parentfix(hm/pkgs/scr/neorg): Remove 'set -e' (diff)
downloadnixos-config-7f158fa65e4b563a22ef9dbf67c7d3a9d34f7b11.zip
fix(hm/conf/taskwarrior/firefox): Generate the profile ids by counting
Firefox expects the IDs to be consecutive, thus the previous hashing
implementation didn't work. Additionally, these IDs are still all unique
as we generate them by iteration over all possible projects
Diffstat (limited to 'hm/soispha/conf/firefox/default.nix')
-rw-r--r--hm/soispha/conf/firefox/default.nix29
1 files changed, 16 insertions, 13 deletions
diff --git a/hm/soispha/conf/firefox/default.nix b/hm/soispha/conf/firefox/default.nix
index 1f3b7062..d35b7256 100644
--- a/hm/soispha/conf/firefox/default.nix
+++ b/hm/soispha/conf/firefox/default.nix
@@ -22,6 +22,20 @@
 
   video-pauser = (import ./functions/extensions/video-pauser.nix) {inherit pkgs video_pause;};
 
+  profiles = {
+    "default" = {
+      inherit extensions search extraConfig bookmarks userChrome;
+      isDefault = true;
+      id = 0;
+      name = "default";
+    };
+    "clean" = {
+      isDefault = false;
+      id = 1;
+      name = "clean";
+    };
+  };
+
   taskwarriorProfiles = import ../taskwarrior/firefox {
     inherit
       extensions
@@ -32,6 +46,7 @@
       lib
       config
       ;
+    profile_size = builtins.length (builtins.attrNames profiles);
   };
 
   search = {
@@ -72,19 +87,7 @@ in {
       };
     };
     profiles =
-      {
-        "default" = {
-          inherit extensions search extraConfig bookmarks userChrome;
-          isDefault = true;
-          id = 0;
-          name = "default";
-        };
-        "clean" = {
-          isDefault = false;
-          id = 1;
-          name = "clean";
-        };
-      }
+      profiles
       // taskwarriorProfiles;
   };
 }