about summary refs log tree commit diff stats
path: root/hm/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
committerSoispha <soispha@vhack.eu>2023-08-26 23:42:21 +0200
commit3f600ab07dbad3b6dd7655587ddea158b19aea71 (patch)
tree7164ccd965e1d14ade970aeb8eb188b1442a6c91 /hm/default.nix
parentStyle(treewide): Format all lua-files makes lua ➛ nix easier (diff)
downloadnixos-config-3f600ab07dbad3b6dd7655587ddea158b19aea71.zip
Refactor(treewide): Abbreviate path names
Diffstat (limited to 'hm/default.nix')
-rw-r--r--hm/default.nix60
1 files changed, 60 insertions, 0 deletions
diff --git a/hm/default.nix b/hm/default.nix
new file mode 100644
index 00000000..015cdeb2
--- /dev/null
+++ b/hm/default.nix
@@ -0,0 +1,60 @@
+{
+  pkgs,
+  sysLib,
+  # extra information
+  system,
+  # bins
+  video_pause,
+  yambar_cpu,
+  yambar_memory,
+  lf_rename,
+  strip_js_comments,
+  river_init_lesser,
+  grades,
+  shell_library,
+  flake_update,
+  # external deps
+  user_js,
+  neovim_config,
+  snap-sync,
+  # modules
+  impermanence,
+  nixNeovim,
+  nixVim,
+}: {
+  home-manager = {
+    useGlobalPkgs = true;
+    useUserPackages = true;
+    users.soispha = import ./soispha;
+    extraSpecialArgs = {
+      inherit
+        pkgs
+        sysLib
+        # extra information
+        
+        system
+        # bins
+        
+        video_pause
+        yambar_cpu
+        yambar_memory
+        lf_rename
+        strip_js_comments
+        river_init_lesser
+        grades
+        shell_library
+        flake_update
+        # external deps
+        
+        user_js
+        neovim_config
+        snap-sync
+        # modules
+        
+        impermanence
+        nixNeovim
+        nixVim
+        ;
+    };
+  };
+}