about summary refs log tree commit diff stats
path: root/flake/packages/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-05-16 16:42:51 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-05-16 16:42:51 +0200
commit8bed94a028a88ed03354cba62a0cccaab6dcb61e (patch)
tree0360a64ea1bfc9c285d5ace0bf27f6f0579e905a /flake/packages/default.nix
parentflake: Rename `nixVim` input to `nixvim` (diff)
downloadnixos-config-8bed94a028a88ed03354cba62a0cccaab6dcb61e.zip
flake: Pack arguments in attribute sets
This avoids having to change 3+ files, if you need to add a new
argument.
Diffstat (limited to 'flake/packages/default.nix')
-rw-r--r--flake/packages/default.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/flake/packages/default.nix b/flake/packages/default.nix
index 89c7c4f6..9c67eda3 100644
--- a/flake/packages/default.nix
+++ b/flake/packages/default.nix
@@ -8,14 +8,9 @@
 # You should have received a copy of the License along with this program.
 # If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
 {
-  self,
-  nixos-generators,
   pkgs,
+  self,
   myPkgs,
-  pkgsStable,
-  sysLib,
-  system,
-  shell_library,
   ...
 }: let
   inherit (pkgs) lib;
@@ -85,8 +80,6 @@ in
     #   format = "install-iso";
     # };
 
-    update_shell_lib = shell_library.packages."${system}".update_shell_library;
-
     # gpg-iso = nixos-generators.nixosGenerate {
     #   system = "x86_64-linux";
     #   specialArgs = defaultSpecialArgs;