about summary refs log tree commit diff stats
path: root/flake/inputs/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-20 08:45:56 +0100
committerene <ene@sils.li>2023-02-20 10:40:41 +0100
commit3ee8467b9a6382641543e2ac485d5c2623e9b0c4 (patch)
treec121a13230b36557eb76890a1f920cfd667efe29 /flake/inputs/default.nix
parentFeat(bootstrap): Add a script for quick activation (diff)
downloadnixos-config-3ee8467b9a6382641543e2ac485d5c2623e9b0c4.zip
Feat(flake): Move the in and outputs to separate files
Diffstat (limited to 'flake/inputs/default.nix')
-rw-r--r--flake/inputs/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/flake/inputs/default.nix b/flake/inputs/default.nix
new file mode 100644
index 00000000..d3300cad
--- /dev/null
+++ b/flake/inputs/default.nix
@@ -0,0 +1,37 @@
+{_}: {
+  nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+  home-manager = {
+    url = "github:nix-community/home-manager/master";
+    inputs.nixpkgs.follows = "nixpkgs";
+  };
+
+  agenix = {
+    url = "github:ryantm/agenix";
+    inputs.nixpkgs.follows = "nixpkgs";
+  };
+  impermanence = {
+    url = "github:nix-community/impermanence";
+  };
+
+  neovim_config = {
+    url = "git+https://codeberg.org/ene/neovim-config.git";
+    flake = false;
+  };
+
+  strip_js_comments = {
+    url = "git+https://codeberg.org/ene/strip_js_comments.git";
+    inputs.nixpkgs.follows = "nixpkgs";
+  };
+  shell-library = {
+    url = "git+https://git.sils.li/ene/lib-sh.git";
+    flake = false;
+  };
+  user_js = {
+    url = "github:arkenfox/user.js";
+    flake = false;
+  };
+  snap-sync = {
+    url = "github:qubidt/snap-sync";
+    flake = false;
+  };
+}