about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-22 17:58:39 +0100
committerene <ene@sils.li>2023-02-22 17:58:39 +0100
commitcda104d1fedcd5f49ae82bfb3e5603e68d0d5e81 (patch)
tree48df62f51ef6fcfd2253582e4598bc191f034599 /flake.nix
parentDocs(todo): Refactor and Update (diff)
downloadnixos-config-cda104d1fedcd5f49ae82bfb3e5603e68d0d5e81.zip
Fix(river): Add further dependency for the init script
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 5fddd222..24f6e5f1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -30,6 +30,11 @@
       url = "git+https://git.sils.li/ene/lib-sh.git";
       flake = false;
     };
+    river_init_lesser = {
+      url = "git+https://git.sils.li/ene/river-lesser-init.git";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
+
     user_js = {
       url = "github:arkenfox/user.js";
       flake = false;
@@ -43,14 +48,18 @@
   outputs = {
     self,
     nixpkgs,
+
     home-manager,
-    neovim_config,
-    strip_js_comments,
-    user_js,
     impermanence,
     agenix,
+
+    neovim_config,
+    user_js,
     snap-sync,
+
+    strip_js_comments,
     shell-library,
+    river_init_lesser,
     ...
   } @ inputs: let
     sysLib = import ./lib {inherit pkgs shell-library;};
@@ -66,7 +75,7 @@
       };
     };
   in {
-    nixosConfigurations = import ./flake/nixosConfigurations {inherit inputs system pkgs sysLib;};
+    nixosConfigurations = import ./flake/nixosConfigurations {inherit inputs system pkgs sysLib river_init_lesser;};
     packages."${system}" = {
       install = import ./bootstrap/install {
         inherit pkgs;