about summary refs log tree commit diff stats
path: root/bootstrap/install/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-20 08:48:00 +0100
committerene <ene@sils.li>2023-02-20 10:36:51 +0100
commit4aa5f378d2e3f6cb570ec85daa17115097a8d371 (patch)
treea79fddc156ed2a8e8b4dc0684fe9773566f1760e /bootstrap/install/default.nix
parentFeat(flake): Reorder hosts (diff)
downloadnixos-config-4aa5f378d2e3f6cb570ec85daa17115097a8d371.zip
Feat(bootstrap): Add a script for quick activation
Diffstat (limited to 'bootstrap/install/default.nix')
-rw-r--r--bootstrap/install/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/bootstrap/install/default.nix b/bootstrap/install/default.nix
new file mode 100644
index 00000000..68580d41
--- /dev/null
+++ b/bootstrap/install/default.nix
@@ -0,0 +1,12 @@
+# vim: ts=2
+{
+  pkgs,
+  shell-library,
+  ...
+}: let
+  dependencies = with pkgs; [jq dash curl grep];
+  name = "install";
+  script = ./install.sh;
+  lib = import ../../lib {inherit pkgs shell-library;};
+in
+  lib.makeShellScriptWithLibrary {inherit dependencies name script;}