about summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 8 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 27d9c05..25b3489 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,12 +15,13 @@ members = [
   "crates/yt_dlp",
   "crates/libmpv2",
   "crates/libmpv2/libmpv2-sys",
+  "crates/termsize",
   "yt",
 ]
 
 [workspace.package]
 edition = "2021"
-version = "1.4.0"
+version = "1.5.0"
 rust-version = "1.80.0"
 authors = ["Benedikt Peetz <benedikt.peetz@b-peetz.de>"]
 repository = "https://git.vhack.eu/soispha/clients/yt"
@@ -32,13 +33,15 @@ description = "A fully featured command line YouTube client"
 yt_dlp = { path = "./crates/yt_dlp" }
 bytes = { path = "./crates/bytes" }
 libmpv2 = { path = "./crates/libmpv2" }
+termsize = { path = "./crates/termsize" }
+uu_fmt = { path = "./crates/fmt" }
 
 # Shared
-log = "0.4.22"
-serde = { version = "1.0.216", features = ["derive"] }
-serde_json = "1.0.133"
+log = "0.4.26"
+serde = { version = "1.0.218", features = ["derive"] }
+serde_json = "1.0.139"
 url = { version = "2.5.4", features = ["serde"] }
-tokio = { version = "1.42.0", features = [
+tokio = { version = "1.43.0", features = [
   "rt-multi-thread",
   "macros",
   "process",