summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 73f27c9..82605f4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,27 +8,32 @@
       url = "github:numtide/flake-utils";
       inputs.systems.follows = "systems";
     };
+    revealjs = {
+      url = "github:hakimel/reveal.js";
+      flake = false;
+    };
   };
 
   outputs = {
     nixpkgs,
     flake-utils,
+    revealjs,
     ...
   }:
     flake-utils.lib.eachDefaultSystem (
       system: let
         pkgs = nixpkgs.legacyPackages.${system};
-        vscode = import ./vscode.nix {inherit pkgs;};
+        vscode-langservers-extracted = import ./vscode-langservers-extracted.nix {inherit pkgs;};
       in {
         devShells = {
           default = pkgs.mkShell {
             packages = with pkgs; [
-              statix
+              alejandra
               ltex-ls
               nil
               shellcheck
-              alejandra
-              vscode
+              statix
+              vscode-langservers-extracted
             ];
           };
         };