summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorbpeetz <me@b-peetz.de>2023-06-25 18:26:52 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-02-22 16:06:45 +0100
commit972cb1438aecca8fac523cba16d221af41038257 (patch)
tree19914a88f2bc129a6cbbfe9b2c2fb3bad33d5b76 /flake.nix
downloadb-peetz.de-972cb1438aecca8fac523cba16d221af41038257.zip
chore: Initial Commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..73f27c9
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,39 @@
+{
+  description = "NixOS flake for my website";
+
+  inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.11-small";
+    systems.url = "github:nix-systems/x86_64-linux";
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs.systems.follows = "systems";
+    };
+  };
+
+  outputs = {
+    nixpkgs,
+    flake-utils,
+    ...
+  }:
+    flake-utils.lib.eachDefaultSystem (
+      system: let
+        pkgs = nixpkgs.legacyPackages.${system};
+        vscode = import ./vscode.nix {inherit pkgs;};
+      in {
+        devShells = {
+          default = pkgs.mkShell {
+            packages = with pkgs; [
+              statix
+              ltex-ls
+              nil
+              shellcheck
+              alejandra
+              vscode
+            ];
+          };
+        };
+      }
+    );
+}
+# vim: ts=2
+