{modulesPath, ...}: {
  imports = [(modulesPath + "/profiles/qemu-guest.nix")];
  boot.loader.grub.device = "/dev/vda";
  boot.initrd.availableKernelModules = ["ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi"];
  boot.initrd.kernelModules = ["nvme" "btrfs"];
  fileSystems = {
    "/" = {
      device = "tmpfs";
      fsType = "tmpfs";
      options = ["defaults" "size=2G" "mode=755"];
    };
    "/nix" = {
      device = "/dev/vda3";
      fsType = "btrfs";
      options = ["subvol=nix" "compress-force=zstd"];
    };
    "/srv" = {
      device = "/dev/vda3";
      fsType = "btrfs";
      options = ["subvol=storage" "compress-force=zstd"];
    };
    "/etc/nixos" = {
      device = "/srv/nix-config";
      options = ["bind"];
    };
  };
}