about summary refs log tree commit diff stats
path: root/tests/common/dns/client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/common/dns/client.nix')
-rw-r--r--tests/common/dns/client.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/common/dns/client.nix b/tests/common/dns/client.nix
new file mode 100644
index 0000000..52f3267
--- /dev/null
+++ b/tests/common/dns/client.nix
@@ -0,0 +1,10 @@
+{
+  lib,
+  nodes,
+  ...
+}: {
+  networking.nameservers = lib.mkForce [
+    nodes.name_server.networking.primaryIPAddress
+    nodes.name_server.networking.primaryIPv6Address
+  ];
+}