about summary refs log tree commit diff stats
path: root/modules/by-name/st/stalwart-mail/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/st/stalwart-mail/module.nix')
-rw-r--r--modules/by-name/st/stalwart-mail/module.nix50
1 files changed, 2 insertions, 48 deletions
diff --git a/modules/by-name/st/stalwart-mail/module.nix b/modules/by-name/st/stalwart-mail/module.nix
index e5a681e..4595c21 100644
--- a/modules/by-name/st/stalwart-mail/module.nix
+++ b/modules/by-name/st/stalwart-mail/module.nix
@@ -2,8 +2,7 @@
   lib,
   config,
   pkgs,
-  pkgsUnstable,
-  nixLib,
+  vhackPackages,
   ...
 }: let
   cfg = config.vhack.stalwart-mail;
@@ -11,46 +10,6 @@
 
   configFormat = pkgs.formats.toml {};
   configFile = configFormat.generate "stalwart-mail.toml" topCfg.settings;
-
-  spamfilter = pkgs.callPackage ./spam-filter.nix {};
-
-  stalwart-mail = pkgsUnstable.stalwart-mail.overrideAttrs (final: prev: {
-    passthru = nixLib.warnMerge (prev.passthru or {}) {
-      inherit spamfilter;
-    } "stalwart-mail passthru";
-
-    checkFlags =
-      (prev.checkFlags or [])
-      ++ [
-        # This started to fail?
-        # TODO(@bpeetz): Find out why. <2025-02-08>
-        "--skip=smtp::outbound::lmtp::lmtp_delivery"
-      ];
-
-    # `stalwart-mail` does enable their `enterprise` feature per default.
-    # We want a AGPL only build (i.e., without unfree dependencies), therefore disable the
-    # `enterprise` feature here.
-    # We cannot use the `buildFeatures` attribute because it does not actually change the
-    # correct features. As such we simply patch the correct `Cargo.toml` file.
-    patches =
-      (prev.patches or [])
-      ++ [
-        ./patches/build-crates-main-Cargo.toml-Activate-appropriate-de.patch
-        ./patches/fix-crates-directory-Guard-all-enterprise-only-featu.patch
-      ];
-
-    # Check that the enterprise feature is really disabled.
-    postCheck =
-      (prev.postCheck or "")
-      +
-      # bash
-      ''
-        if grep "enterprise" ./target/*/release/stalwart-mail.d; then
-          echo "ERROR: Proprietary 'enterprise' feature active."
-          exit 1
-        fi
-      '';
-  });
 in {
   imports = [
     ./settings.nix
@@ -59,12 +18,7 @@ in {
   options.vhack.stalwart-mail = {
     enable = lib.mkEnableOption "starwart-mail";
 
-    # package = lib.mkPackageOption pkgsUnstable "stalwart-mail" {pkgsText = "pkgsUnstable";};
-    package = lib.mkOption {
-      description = "The stalwart-mail package to use";
-      type = lib.types.package;
-      default = stalwart-mail;
-    };
+    package = lib.mkPackageOption vhackPackages "stalwart-mail-free" {};
 
     fqdn = lib.mkOption {
       type = lib.types.str;