about summary refs log tree commit diff stats
path: root/hosts/by-name/server2/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/by-name/server2/configuration.nix43
1 files changed, 11 insertions, 32 deletions
diff --git a/hosts/by-name/server2/configuration.nix b/hosts/by-name/server2/configuration.nix
index 7f0502d..ba0de14 100644
--- a/hosts/by-name/server2/configuration.nix
+++ b/hosts/by-name/server2/configuration.nix
@@ -1,4 +1,8 @@
-{config, ...}: {
+{
+  config,
+  lib,
+  ...
+}: {
   imports = [
     ./networking.nix # network configuration that just works
     ./hardware.nix
@@ -33,7 +37,7 @@
         "185.16.61.132"
         "2a03:4000:a:106::1"
       ];
-      zones = import ../../../zones {};
+      zones = import ../../../zones {inherit lib;};
     };
     etesync = {
       enable = true;
@@ -57,36 +61,10 @@
       enable = true;
       fqdn = "mail.foss-syndicate.org";
     };
-    stalwart-mail = {
-      enable = false;
-      fqdn = "mail.vhack.eu";
-      admin = "admin@vhack.eu";
-      security = {
-        dkimKeys = let
-          loadKey = name: {
-            dkimPublicKey = builtins.readFile (./secrets/dkim + "/${name}-public");
-            dkimPrivateKeyPath = ./secrets/dkim + "/${name}-private.age";
-            keyAlgorithm = "ed25519-sha256";
-          };
-        in {
-          "mail.vhack.eu" = loadKey "mail.vhack.eu";
-        };
-        verificationMode = "strict";
-      };
-      openFirewall = true;
-      principals = [
-        {
-          class = "individual";
-          name = "soispha";
-          secret = "$2b$05$XX36sJuHNbTFvi8DFldscOeQBHahluSkiUqD9QGzQaET7NJusSuQW";
-          email = [
-            "soispha@vhack.eu"
-            "abuse@vhack.eu"
-            "postmaster@vhack.eu"
-            "admin@vhack.eu"
-          ];
-        }
-      ];
+    nextcloud = {
+      enable = true;
+      hostname = "nextcloud.vhack.eu";
+      adminpassFile = ./secrets/nextcloud/adminpassFile.age;
     };
     nginx = {
       enable = true;
@@ -105,6 +83,7 @@
     };
     redlib.enable = true;
     rust-motd.enable = true;
+    taskchampion-sync.enable = true;
     users.enable = true;
   };