summary refs log tree commit diff stats
path: root/hosts/by-name/server1/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/by-name/server1/configuration.nix (renamed from hosts/server1/configuration.nix)14
1 files changed, 13 insertions, 1 deletions
diff --git a/hosts/server1/configuration.nix b/hosts/by-name/server1/configuration.nix
index e21327e..6bb1067 100644
--- a/hosts/server1/configuration.nix
+++ b/hosts/by-name/server1/configuration.nix
@@ -3,7 +3,7 @@
     ./networking.nix # network configuration that just works
     ./hardware.nix
 
-    ../../system
+    ../../../system
   ];
 
   vhack = {
@@ -22,7 +22,19 @@
     nix-sync.enable = true;
     openssh.enable = true;
     peertube.enable = true;
+    postgresql.enable = true;
     redlib.enable = true;
+    users.enable = true;
+    persist = {
+      enable = true;
+      directories = [
+        "/var/log"
+
+        # TODO(@bpeetz): Instead of persisting that, encode each uid/gid directly in the
+        # config. <2024-12-24>
+        "/var/lib/nixos"
+      ];
+    };
   };
 
   boot.tmp.cleanOnBoot = true;