about summary refs log tree commit diff stats
path: root/tests/by-name/em/email-http/nodes/user.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-12 16:28:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-12 16:28:46 +0200
commit80ec9fe451af906884687efaa5331c0c436655cf (patch)
tree0841e1ea36458eb846d1e9987edfb197bb8be8f9 /tests/by-name/em/email-http/nodes/user.nix
parenttests/email-dns: Factor out all of the secrets/acme stuff into a common dir (diff)
downloadnixos-server-80ec9fe451af906884687efaa5331c0c436655cf.zip
tests/email-http: Test the http self-service availability
Diffstat (limited to 'tests/by-name/em/email-http/nodes/user.nix')
-rw-r--r--tests/by-name/em/email-http/nodes/user.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/by-name/em/email-http/nodes/user.nix b/tests/by-name/em/email-http/nodes/user.nix
new file mode 100644
index 0000000..73b9ff7
--- /dev/null
+++ b/tests/by-name/em/email-http/nodes/user.nix
@@ -0,0 +1,26 @@
+{
+  pkgs,
+  vhackPackages,
+}: {
+  mkUser = user: serverName: {
+    nodes,
+    lib,
+    ...
+  }: {
+    imports = [
+      ../../../../common/acme/client.nix
+    ];
+
+    environment.systemPackages = [
+      pkgs.bind
+      pkgs.openssl
+    ];
+
+    networking.nameservers = lib.mkForce [
+      nodes.name_server.networking.primaryIPAddress
+      nodes.name_server.networking.primaryIPv6Address
+    ];
+
+    users.users."${user}" = {isNormalUser = true;};
+  };
+}