about summary refs log tree commit diff stats
path: root/tests/by-name/em/email-http/nodes/user.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-12 16:28:46 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-23 12:10:33 +0200
commit2452418a7a3aea1ecfd54f135f4814e0c51b946c (patch)
tree997a1107995930d3f036544f7690d4d46d5296dd /tests/by-name/em/email-http/nodes/user.nix
parentmodules/stalwart-mail: Don't restart the systemd service (diff)
downloadnixos-server-2452418a7a3aea1ecfd54f135f4814e0c51b946c.zip
tests/email-http: Test the http self-service availability
Diffstat (limited to '')
-rw-r--r--tests/by-name/em/email-http/nodes/user.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/by-name/em/email-http/nodes/user.nix b/tests/by-name/em/email-http/nodes/user.nix
new file mode 100644
index 0000000..73b9ff7
--- /dev/null
+++ b/tests/by-name/em/email-http/nodes/user.nix
@@ -0,0 +1,26 @@
+{
+  pkgs,
+  vhackPackages,
+}: {
+  mkUser = user: serverName: {
+    nodes,
+    lib,
+    ...
+  }: {
+    imports = [
+      ../../../../common/acme/client.nix
+    ];
+
+    environment.systemPackages = [
+      pkgs.bind
+      pkgs.openssl
+    ];
+
+    networking.nameservers = lib.mkForce [
+      nodes.name_server.networking.primaryIPAddress
+      nodes.name_server.networking.primaryIPv6Address
+    ];
+
+    users.users."${user}" = {isNormalUser = true;};
+  };
+}