about summary refs log tree commit diff stats
path: root/modules/by-name/st/stalwart-mail/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-11 11:50:13 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-12 14:39:08 +0200
commit38244f5cc557786fc56d17c8d24bcd334e73b58a (patch)
tree5bed68a14c2f8b9dc82d6f3623b714a95c202704 /modules/by-name/st/stalwart-mail/module.nix
parentmodules/stalwart-mail: Use correct group name for `redis-stalwart-mail` (diff)
downloadnixos-server-38244f5cc557786fc56d17c8d24bcd334e73b58a.zip
modules/stalwart-mail: Make `cfg.principals` nullable
This makes it possible to use the internal storage
Diffstat (limited to '')
-rw-r--r--modules/by-name/st/stalwart-mail/module.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/by-name/st/stalwart-mail/module.nix b/modules/by-name/st/stalwart-mail/module.nix
index ae3ccea..1e39e81 100644
--- a/modules/by-name/st/stalwart-mail/module.nix
+++ b/modules/by-name/st/stalwart-mail/module.nix
@@ -41,8 +41,8 @@ in {
     };
 
     principals = lib.mkOption {
-      default = [];
-      type = lib.types.listOf (lib.types.submodule {
+      default = null;
+      type = lib.types.nullOr (lib.types.listOf (lib.types.submodule {
         options = {
           name = lib.mkOption {
             type = lib.types.str;
@@ -77,7 +77,7 @@ in {
             '';
           };
         };
-      });
+      }));
     };
 
     dataDirectory = lib.mkOption {