about summary refs log tree commit diff stats
path: root/modules/by-name/ni/nixconfig/module.nix
diff options
context:
space:
mode:
authorSilas Schöffel <sils@sils.li>2025-01-20 16:24:59 +0100
committerSilas Schöffel <sils@sils.li>2025-01-20 16:24:59 +0100
commit958f969592d51f69e63d28fb7af3d4c5e0488bab (patch)
treebe1f0cc345ee6d61a41ed728064e59d6e97c6f57 /modules/by-name/ni/nixconfig/module.nix
parentfeat(modules/invidious-router): init (diff)
downloadnixos-server-958f969592d51f69e63d28fb7af3d4c5e0488bab.zip
feat(modules/nixconfig): init
Diffstat (limited to '')
-rw-r--r--modules/by-name/ni/nixconfig/module.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/by-name/ni/nixconfig/module.nix b/modules/by-name/ni/nixconfig/module.nix
new file mode 100644
index 0000000..a5bf950
--- /dev/null
+++ b/modules/by-name/ni/nixconfig/module.nix
@@ -0,0 +1,28 @@
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.vhack.nixconfig;
+in {
+  options.vhack.nixconfig = {
+    enable = lib.mkEnableOption "sophisticated nix settings";
+  };
+  config = lib.mkIf cfg.enable {
+    nix = {
+      #    gc = {
+      #      automatic = true;
+      #      dates = "daily";
+      #      options = "--delete-older-than 3";
+      #    };
+      settings = {
+        auto-optimise-store = true;
+        experimental-features = ["nix-command" "flakes"];
+        trusted-users = [
+          "root"
+          "@wheel"
+        ];
+      };
+    };
+  };
+}