about summary refs log tree commit diff stats
path: root/modules/by-name/co/constants/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-03-29 15:24:47 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-03-29 15:24:47 +0100
commitb8c7040e98004c355522db339c6c8172b4f04d30 (patch)
tree600c9a39c9f3091afd31dd8bba41c2974bb98f66 /modules/by-name/co/constants/module.nix
parentmodules/constants: Correctly assign each uid so that none is greater 400 (diff)
downloadnixos-server-b8c7040e98004c355522db339c6c8172b4f04d30.zip
modules/constants: Enforce the 0 to 400 limit
Diffstat (limited to '')
-rw-r--r--modules/by-name/co/constants/module.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/by-name/co/constants/module.nix b/modules/by-name/co/constants/module.nix
index 54e8d81..67d1601 100644
--- a/modules/by-name/co/constants/module.nix
+++ b/modules/by-name/co/constants/module.nix
@@ -11,14 +11,14 @@
       description = ''
         The user IDs used in the vhack.eu nixos config.
       '';
-      type = lib.types.attrsOf lib.types.int;
+      type = lib.types.attrsOf (lib.types.ints.between 0 400);
     };
     ids.gids = lib.mkOption {
       internal = true;
       description = ''
         The group IDs used in the vhack.eu nixos config.
       '';
-      type = lib.types.attrsOf lib.types.int;
+      type = lib.types.attrsOf (lib.types.ints.between 0 400);
     };
   };