about summary refs log tree commit diff stats
path: root/hosts/by-name/server2/configuration.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-03-29 15:13:28 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-03-29 15:13:28 +0100
commit6ee59c8ca5281bd55779c2828e8ea45ca8c88051 (patch)
tree6a90ee2a4fe252ae54ba9a407ad7eb88f4ffdcd2 /hosts/by-name/server2/configuration.nix
parenthosts/server2: Setup stalwalt-mail on mail.vhack.eu for soispha@vhack.eu (diff)
downloadnixos-server-6ee59c8ca5281bd55779c2828e8ea45ca8c88051.zip
hosts/server2: Use the correct path to the DKIM keys
Diffstat (limited to '')
-rw-r--r--hosts/by-name/server2/configuration.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/hosts/by-name/server2/configuration.nix b/hosts/by-name/server2/configuration.nix
index cbc1ff3..90da548 100644
--- a/hosts/by-name/server2/configuration.nix
+++ b/hosts/by-name/server2/configuration.nix
@@ -64,12 +64,12 @@
       security = {
         dkimKeys = let
           loadKey = name: {
-            dkimPublicKey = builtins.readFile (./secrets/dkim + "/${name}/public");
-            dkimPrivateKeyPath = ./secrets/dkim + "/${name}/private.age";
+            dkimPublicKey = builtins.readFile (./secrets/dkim + "/${name}-public");
+            dkimPrivateKeyPath = ./secrets/dkim + "/${name}-private.age";
             keyAlgorithm = "ed25519-sha256";
           };
         in {
-          "mail.vhack.eu" = loadKey "vhack.eu";
+          "mail.vhack.eu" = loadKey "mail.vhack.eu";
         };
         verificationMode = "strict";
       };