summary refs log tree commit diff stats
path: root/by-name-overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--by-name-overlay.nix12
1 files changed, 1 insertions, 11 deletions
diff --git a/by-name-overlay.nix b/by-name-overlay.nix
index 84393b0..3e52e64 100644
--- a/by-name-overlay.nix
+++ b/by-name-overlay.nix
@@ -14,8 +14,6 @@
   baseDirectory,
   fileName,
   finalizeFunction ? name: value: value,
-  coImportsNameFunction ? null,
-  coImportsWarnMessageObject ? null,
   useShards ? true,
 }: let
   # Takes a list of attrs as input and returns one merged attr set.
@@ -60,12 +58,6 @@
   namesForElement = shard: _type: let
     mkPath = name: type: let
       path = baseDirectory + "/${shard}/${name}" + "/${fileName}";
-      coImportPath =
-        if coImportsNameFunction != null
-        then
-          coImportsNameFunction
-          {inherit shard name;}
-        else path;
     in
       if builtins.pathExists path
       then
@@ -73,9 +65,7 @@
         then
           # The `namesForShard` function should have already printed a warning.
           null
-        else if builtins.pathExists coImportPath
-        then path
-        else warn "'${builtins.toString coImportPath}' does not exist. Should include ${coImportsWarnMessageObject} for '${shard}/${name}'" path
+        else path
       else warn "'${builtins.toString path}' does not exist. Skipped" null;
   in
     filterAttrs (name: value: value != null)