summary refs log tree commit diff stats
path: root/by-name-overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--by-name-overlay.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/by-name-overlay.nix b/by-name-overlay.nix
index c578861..2d03e75 100644
--- a/by-name-overlay.nix
+++ b/by-name-overlay.nix
@@ -82,7 +82,7 @@ assert fileRegex == null -> fileName != null; let
       then namesForElementShard shard type
       else namesForElementDirect shard type;
 
-    # Type: String -> String -> ListOf Path
+    # Type: String -> String -> String -> ListOf Path
     mkPath = shard: name: toplevelType: let
       rawPath = baseDirectory + "/${shard}/${name}";
       paths = filterAttrs (_: v: v != null) (mapAttrs' (name: value:
@@ -91,7 +91,7 @@ assert fileRegex == null -> fileName != null; let
         else nameValuePair name null) (builtins.readDir rawPath));
 
       checkPath = pathSegment: type: let
-        path = "${rawPath}/${pathSegment}";
+        path = rawPath + "/${pathSegment}";
       in
         if builtins.pathExists path
         then
@@ -109,7 +109,7 @@ assert fileRegex == null -> fileName != null; let
         # The `namesForShard` function should have already printed a warning.
         [null]
       else if (builtins.attrValues paths) == []
-      then warn "'${fileDisplay}' did not match anything in ${rawPath}. Skipped" [null]
+      then warn "'${fileDisplay}' did not match anything in ${builtins.toString rawPath}. Skipped" [null]
       else mapAttrsToList checkPath paths;
 
     filterNull = list: builtins.filter (value: value != null) list;