summary refs log tree commit diff stats
path: root/hm/zsh/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/zsh/default.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/hm/zsh/default.nix b/hm/zsh/default.nix
index 684493f..88a429d 100644
--- a/hm/zsh/default.nix
+++ b/hm/zsh/default.nix
@@ -2,6 +2,7 @@
   config,
   pkgs,
   self,
+  lib,
   ...
 }: {
   programs.zsh = {
@@ -61,12 +62,10 @@
       addapache = "curl https://www.apache.org/licenses/LICENSE-2.0.txt > LICENSE";
     };
 
-    initExtraFirst =
-      builtins.readFile ./config/instant-prompt.zsh
-      + "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
-    # +
-    initExtra =
-      ''
+    initContent = lib.mkBefore (builtins.readFile ./config/instant-prompt.zsh
+      + "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme"
+      + ''
+
         rm -rf ~/.mozilla/firefox/default/containers.json.backup
 
         export ZSH=${pkgs.oh-my-zsh}/share/oh-my-zsh/
@@ -80,6 +79,6 @@
           source $ZSH/oh-my-zsh.sh
       ''
       + builtins.readFile ./config/p10k.zsh
-      + builtins.readFile ./config/functions.zsh;
+      + builtins.readFile ./config/functions.zsh);
   };
 }