summary refs log tree commit diff stats
path: root/sys/users/default.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-05-04 18:17:38 +0200
committersils <sils@sils.li>2023-05-04 18:17:38 +0200
commit4eaf76cf1e0af9ec7a630320bb7d4956041dd03e (patch)
tree4073ad033ef5f0939e76bb82a75847b34ca4bba9 /sys/users/default.nix
parentChore(flake): Update (diff)
downloadnix-config-4eaf76cf1e0af9ec7a630320bb7d4956041dd03e.zip
Structure(treewide): Use new structure with home-manager
                     home-manager enables great possibilities and is
                     part of simplifying the structure of my config.
Diffstat (limited to 'sys/users/default.nix')
-rw-r--r--sys/users/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys/users/default.nix b/sys/users/default.nix
new file mode 100644
index 0000000..7f1e7d2
--- /dev/null
+++ b/sys/users/default.nix
@@ -0,0 +1,22 @@
+{pkgs, ...}: {
+  users = {
+    mutableUsers = false;
+    users.sils = {
+      isNormalUser = true;
+      home = "/home/sils";
+      shell = pkgs.zsh;
+      initialHashedPassword = "$y$j9T$r4578Hy9jZHmUH9uSr9OI.$SuR2anRq7EJ1gUJ6vi9qYmZrhLP.o3O5643IG6r5Ap/";
+      extraGroups = ["wheel" "networkmanager"];
+    };
+    users.cnnr = {
+      isNormalUser = true;
+      home = "/home/cnnr";
+      shell = pkgs.zsh;
+      initialHashedPassword = "$y$j9T$NFz0d2coUOvl.hL3YRwEY0$8btvXUoWGWwo11ksdt8eIFUljCkpUe0YliEy7l0odU1";
+    };
+  };
+  services.xserver.displayManager.autoLogin = {
+    enable = true;
+    user = "sils";
+  };
+}