summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 33ff880..4e472d3 100644
--- a/flake.nix
+++ b/flake.nix
@@ -54,6 +54,18 @@
       formatter = treefmtEval.config.build.wrapper;
 
       devShells.default = pkgs.mkShell {
+        nativeBuildInputs = [
+          pkgs.pkg-config
+
+          pkgs.wayland-scanner
+          pkgs.meson
+          pkgs.ninja
+        ];
+        buildInputs = [
+          pkgs.libudev-zero
+          pkgs.kdePackages.wayland.dev
+          pkgs.hidapi
+        ];
         packages = with pkgs; [
           format_layer