{
  mkTest,
  extraModules,
  pkgs,
  ...
}:
mkTest {
  name = "nvim-neorg";

  configuration = {
    imports = [
      ../../../../modules/by-name/nv/nvim/module.nix
      ../../../../modules/by-name/ni/nixpkgs/module.nix
    ];
    config = {
      soispha = {
        nixpkgs = {
          enable = true;
          systemName = "x86_64-linux";
        };
        programs.nvim = {
          enable = true;
          shell = pkgs.zsh;
        };
      };
      home-manager.users.soispha = {
        imports = [
          extraModules.nixvim.homeManagerModule
        ];
      };
    };
  };

  alternateScreen = false;

  testData = {
    "/home/soispha/repos/notes/general/index.norg" = ./data/index.norg;
    "/home/soispha/repos/notes/general/reference.norg" = ./data/reference.norg;
  };

  description = ./test.desc;

  # The golden file is just full of nvim's terminal control sequences. There is no point
  # in trying to check it.
  hash = null;
}