{
  mkTest,
  extraModules,
  pkgs,
  ...
}:
mkTest {
  name = "nvim-checkhealth";

  configuration = {
    imports = [
      ../../../../modules/by-name/nv/nvim/module.nix
      ../../../../modules/by-name/ni/nixpkgs/module.nix
    ];
    config = {
      soispha = {
        nixpkgs = {
          enable = true;
          systemName = "x86_64-linux";
        };
        programs.nvim = {
          enable = true;
          shell = pkgs.zsh;
        };
      };
      home-manager.users.soispha = {
        home.packages = [
          pkgs.bat
          pkgs.ripgrep
          pkgs.bat-extras.batgrep
        ];
        imports = [
          extraModules.nixvim.homeManagerModule
        ];
      };
    };
  };

  testData = {};

  description = ./test.desc;

  # FIXME: This is not reproducible, but is also not checked via `Expect`s. As such this
  # whole test is quite useless, but it might work some day. <2024-11-30>
  hash = null;
}