{pkgs, ...}: {
  services.dbus.enable = true;
  xdg = {
    portal = {
      enable = true;
      config = {
        common = {
          # NOTE: The next entry is supposedly needed for gtk based apps <2023-08-31>
          default = ["gtk"];
        };

        # TODO: Also activate, when on another wlr-based compositor <2023-11-25>
        river = {
          default = ["wlr"];
        };
      };
      extraPortals = with pkgs; [
        xdg-desktop-portal-gtk
        xdg-desktop-portal-wlr
      ];
    };
  };
  # TODO: mime = {};
}