# You can use this file as a nixpkgs overlay. This is useful in the
# case where you don't want to add the whole NUR namespace to your
# configuration.
{sysLib}: self: super: let
  nameValuePair = n: v: {
    name = n;
    value = v;
  };
  packages = import ./default.nix {
    pkgs = super;
    inherit sysLib;
  };
in
  builtins.listToAttrs
  (map (n: nameValuePair n packages.${n})
    (builtins.attrNames packages))