{
  pkgs ? (builtins.getFlake "nixpkgs").legacyPackages."x86_64-linux",
  sysLib ? builtins.trace "Moking `sysLib`" {},
  nixLib ? import ../lib {},
}: let
  inherit (pkgs) lib;

  # FIXME: Make this override check actually work.
  # I think that some parts of the lazy eval are causing that to not actually evaluate the
  # error message. <2024-10-23>
  maybeMergeMessage = "While merging the pkgs in ./pkgs/by-name to the nixpkgs set.";
  mMM = maybeMergeMessage;
  callPackage = lib.callPackageWith (nixLib.maybeMerge (nixLib.maybeMerge pkgs myPkgs mMM) {inherit sysLib;} mMM);

  myPkgs = nixLib.mkByName {
    baseDirectory = ./by-name;
    fileName = "package.nix";
    finalizeFunction = name: value: callPackage value {};
  };
in
  # TODO: Filter the sources of every package in the shards <2024-05-25>
  myPkgs