{
  lib,
  config,
  ...
}: let
  cfg = config.soispha.laptop;
in {
  # TODO: Add an actual config to this module, instead of the implicit one in home manager. <2024-05-22>
  options.soispha.laptop = {
    enable = lib.mkEnableOption "Laptop improvements";
    backlight = lib.mkOption {
      type = lib.types.str;
      example = lib.mdDoc "intel_backlight";
      description = lib.mdDoc "Which backlight to query for the screen brightness";
    };
  };
}