{lib, ...}: {
  # This configures the program in itself (i.e., sets-up a config file, etc.)
  programs.mbsync = {
    enable = true;
  };

  # This starts a systemd service to periodically sync mail
  services.mbsync = {
    enable = true;
  };

  # Disable the timer, and only activate the service when neomutt starts
  # Otherwise, the password command would prompt me to unlock the keepassxc database every
  # time.
  systemd.user.timers.mbsync = lib.mkForce {};
}