{
  config,
  lib,
  ...
}: let
  cfg = config.soispha.programs.nvim;
in {
  home-manager.users.soispha.programs.nixvim.plugins.telescope.keymaps = lib.mkIf cfg.enable {
    "<space>rg" = {
      action = "live_grep";
      options = {
        desc = "[rg] in a live session";
      };
    };
  };
}