{
  config,
  pkgs,
  ...
}: {
  xdg.configFile."swayidle/config".source = ./config;

  #  services.swayidle = {
  #    enable = true;
  #    events = [
  #      {
  #        event = "before-sleep";
  #        command = "${pkgs.swaylock}/bin/swaylock -f ";
  #      }
  #    ];
  #    timeouts = [
  #      {
  #        timeout = 180;
  #        command = "${pkgs.swaylock}/bin/swaylock -fFu ";
  #      }
  #      {
  #        timeout = 360;
  #        # TODO systemctl is installed?
  #        command = "systemctl suspend-then-hibernate";
  #      }
  #    ];
  #    # systemdTarget = ""; # TODO this might be usefull
  #  };
}
# vim: ts=2