{lib, ...}: let
  config_file = ''
    ${lib.strings.fileContents ./toml/base.toml}
    ${lib.strings.fileContents ./toml/bell.toml}
    ${lib.strings.fileContents ./toml/colorscheme.toml}
    ${lib.strings.fileContents ./toml/cursor.toml}
    ${lib.strings.fileContents ./toml/env.toml}
    ${lib.strings.fileContents ./toml/font.toml}
    ${lib.strings.fileContents ./toml/hints.toml}
    ${lib.strings.fileContents ./toml/keyboard_bindings.toml}
    ${lib.strings.fileContents ./toml/mouse.toml}
    ${lib.strings.fileContents ./toml/mouse_bindings.toml}
    ${lib.strings.fileContents ./toml/scrolling.toml}
    ${lib.strings.fileContents ./toml/selection.toml}
    ${lib.strings.fileContents ./toml/window.toml}
  '';
in {
  home.sessionVariables = {
    # This is **not** the TERM variable but a special one to signify my favorite terminal.
    TERMINAL = "alacritty";

    # These two here should be set by alacritty at start-up
    # TERM = "alacritty";
    # COLORTERM = "truecolor";
  };
  programs.alacritty = {
    enable = true;
  };
  xdg.configFile."alacritty/alacritty.toml".text = config_file;
}