From c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c Mon Sep 17 00:00:00 2001
From: Benedikt Peetz <benedikt.peetz@b-peetz.de>
Date: Fri, 18 Oct 2024 17:07:46 +0200
Subject: refactor(modules): Move all system modules to `by-name`

From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
---
 modules/system/services/system_diff/default.nix | 26 -------------------------
 1 file changed, 26 deletions(-)
 delete mode 100644 modules/system/services/system_diff/default.nix

(limited to 'modules/system/services/system_diff/default.nix')

diff --git a/modules/system/services/system_diff/default.nix b/modules/system/services/system_diff/default.nix
deleted file mode 100644
index 052ffae2..00000000
--- a/modules/system/services/system_diff/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  ...
-}: let
-  cfg = config.soispha.services.systemDiff;
-in {
-  options.soispha.services.systemDiff = {
-    enable = lib.mkEnableOption "nvd run at system activation";
-  };
-
-  config = lib.mkIf cfg.enable {
-    system.activationScripts.diff = {
-      supportsDryActivation = true;
-      text = ''
-        PATH="${lib.makeBinPath [pkgs.nvd config.nix.package]}:$PATH"
-
-        if [ -e /run/current-system ]; then
-          # ${lib.getExe config.nix.package} --extra-experimental-features nix-command store diff-closures /run/current-system "$systemConfig"
-          nvd diff $(ls -dv /nix/var/nix/profiles/system-*-link | tail -2)
-        fi
-      '';
-    };
-  };
-}
-- 
cgit 1.4.1