From fd9b0ecef4142a62b45404700ba1cff488f84a73 Mon Sep 17 00:00:00 2001
From: Benedikt Peetz <benedikt.peetz@b-peetz.de>
Date: Thu, 23 May 2024 13:31:11 +0200
Subject: refactor(modules/home): Setup as "normal" NixOS module

---
 modules/home/conf/mbsync/default.nix | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 modules/home/conf/mbsync/default.nix

(limited to 'modules/home/conf/mbsync/default.nix')

diff --git a/modules/home/conf/mbsync/default.nix b/modules/home/conf/mbsync/default.nix
new file mode 100644
index 00000000..ac9808c9
--- /dev/null
+++ b/modules/home/conf/mbsync/default.nix
@@ -0,0 +1,17 @@
+{
+  config,
+  lib,
+  ...
+}: {
+  # TODO: I have no clue if both are needed, but it looks neat, right?
+  programs.mbsync = {
+    enable = true;
+  };
+  services.mbsync = {
+    enable = true;
+    # TODO: enable after isync 1.5 drops
+    #configFile = "${config.xdg.configHome}/mbsync/mbsync.conf";
+  };
+  # Disable the timer, and only activate it on neomutt start
+  systemd.user.timers.mbsync = lib.mkForce {};
+}
-- 
cgit 1.4.1