From c52c7f314ccadcc2fcd91e28c8fd1b88f6d5ce0c Mon Sep 17 00:00:00 2001
From: Benedikt Peetz <benedikt.peetz@b-peetz.de>
Date: Fri, 18 Oct 2024 17:07:46 +0200
Subject: refactor(modules): Move all system modules to `by-name`

From now on all modules should be added to the new `by-name` directory.
This should help remove the (superficial and utterly useless)
distinction between `home-manager` and `NixOS` modules.
---
 modules/by-name/sc/scanning/module.nix | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 modules/by-name/sc/scanning/module.nix

(limited to 'modules/by-name/sc/scanning/module.nix')

diff --git a/modules/by-name/sc/scanning/module.nix b/modules/by-name/sc/scanning/module.nix
new file mode 100644
index 00000000..dda507fa
--- /dev/null
+++ b/modules/by-name/sc/scanning/module.nix
@@ -0,0 +1,25 @@
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}: let
+  cfg = config.soispha.services.scanning;
+in {
+  options.soispha.services.scanning = {
+    enable = lib.mkEnableOption "default scanning configuration";
+  };
+
+  config = lib.mkIf cfg.enable {
+    hardware = {
+      sane = {
+        enable = true;
+        extraBackends = [pkgs.sane-airscan];
+      };
+    };
+
+    users.users.soispha.extraGroups = [
+      "scanner" # for permission to access the scanner.
+    ];
+  };
+}
-- 
cgit 1.4.1