about summary refs log tree commit diff stats
path: root/sys/disks/hibernate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/disks/hibernate.nix')
-rw-r--r--sys/disks/hibernate.nix44
1 files changed, 0 insertions, 44 deletions
diff --git a/sys/disks/hibernate.nix b/sys/disks/hibernate.nix
deleted file mode 100644
index ad7ca12c..00000000
--- a/sys/disks/hibernate.nix
+++ /dev/null
@@ -1,44 +0,0 @@
-{pkgs}: {
-  services = {
-    hibernate-preparation = {
-      wantedBy = ["systemd-hibernate.service"];
-      unitConfig = {
-        Description = "Enable swap file and disable zram before hibernate";
-        Before = "systemd-hibernate.service";
-      };
-      serviceConfig = {
-        Type = "oneshot";
-        User = "root";
-        ExecStart = "${pkgs.bash}/bin/bash -c \"${pkgs.util-linux}/bin/swapon /swap/swapfile && ${pkgs.util-linux}/bin/swapoff /dev/zram0\"";
-      };
-    };
-    hibernate-resume = {
-      wantedBy = ["systemd-hibernate.service"];
-      unitConfig = {
-        Description = "Disable swap after resuming from hibernation";
-        After = "hibernate.target";
-      };
-      serviceConfig = {
-        Type = "oneshot";
-        User = "root";
-        ExecStart = "${pkgs.util-linux}/bin/swapoff /swap/swapfile";
-      };
-    };
-    # swapoff-start = {
-    #      wantedBy = ["multi-user.target"];
-    #      unitConfig = {
-    #        Description = "Disable hardware swap after booting";
-    #      };
-    #      serviceConfig = {
-    #        Type = "oneshot";
-    #        User = "root";
-    #        ExecStart = "${pkgs.util-linux}/bin/swapoff /swap/swapfile";
-    #      };
-    #    };
-    systemd-hibernate.serviceConfig.Environment = "SYSTEMD_BYPASS_HIBERNATION_MEMORY_CHECK=1";
-    systemd-logind.serviceConfig.Environment = "SYSTEMD_BYPASS_HIBERNATION_MEMORY_CHECK=1";
-  };
-  sleep.extraConfig = ''
-    HibernateDelaySec=5m
-  '';
-}