about summary refs log tree commit diff stats
path: root/pkgs/sources/yt/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sources/yt/default.nix')
-rw-r--r--pkgs/sources/yt/default.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/pkgs/sources/yt/default.nix b/pkgs/sources/yt/default.nix
new file mode 100644
index 00000000..32396051
--- /dev/null
+++ b/pkgs/sources/yt/default.nix
@@ -0,0 +1,51 @@
+[
+  (
+    final: prev: {
+      yt = import ./yt.nix {
+        inherit
+          (prev)
+          lib
+          makeWrapper
+          rustPlatform
+          # dependencies
+          
+          ytcc
+          yt-dlp
+          mpv
+          ;
+      };
+    }
+  )
+  (
+    final: prev: {
+      yts = import ./yts.nix {
+        inherit
+          (prev)
+          lib
+          makeWrapper
+          rustPlatform
+          # dependencies
+          
+          ytcc
+          ;
+      };
+    }
+  )
+  (
+    final: prev: {
+      ytc = import ./ytc.nix {
+        inherit
+          (prev)
+          lib
+          makeWrapper
+          rustPlatform
+          # dependencies
+          
+          ytcc
+          yt-dlp
+          mpv
+          ;
+      };
+    }
+  )
+]