about summary refs log tree commit diff stats
path: root/pkgs/sources/update_vim_plugins/package.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sources/update_vim_plugins/package.nix')
-rw-r--r--pkgs/sources/update_vim_plugins/package.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/pkgs/sources/update_vim_plugins/package.nix b/pkgs/sources/update_vim_plugins/package.nix
new file mode 100644
index 00000000..e74a29b1
--- /dev/null
+++ b/pkgs/sources/update_vim_plugins/package.nix
@@ -0,0 +1,47 @@
+{
+  python3,
+  # dependencies
+  nix,
+  alejandra,
+  nix-prefetch-git,
+}:
+python3.pkgs.buildPythonApplication {
+  pname = "update-vim-plugins";
+  version = "0.1.0";
+  format = "pyproject";
+
+  src = ./.;
+
+  # NOTE: The test are not really meant to work <2023-12-09>
+  doCheck = false;
+
+  nativeBuildInputs = [
+    python3.pkgs.poetry-core
+  ];
+  buildInputs = [
+    alejandra
+    nix-prefetch-git
+    nix
+  ];
+  propagatedBuildInputs = with python3.pkgs; [
+    requests
+    cleo
+    jsonpickle
+    dateparser
+  ];
+  nativeCheckInputs = with python3.pkgs; [
+    pytestCheckHook
+
+    pytest-cov
+    pytest-mock
+  ];
+  pytestFlagsArray = [
+    "--cov"
+    "update_vim_plugins"
+    "--cov-report"
+    "term-missing:skip-covered"
+    "--cov-fail-under"
+    "50"
+    "update_vim_plugins/tests"
+  ];
+}