about summary refs log tree commit diff stats
path: root/modules/home.legacy/conf/xdg/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/home.legacy/conf/xdg/default.nix30
1 files changed, 13 insertions, 17 deletions
diff --git a/modules/home.legacy/conf/xdg/default.nix b/modules/home.legacy/conf/xdg/default.nix
index 4099720d..9751d806 100644
--- a/modules/home.legacy/conf/xdg/default.nix
+++ b/modules/home.legacy/conf/xdg/default.nix
@@ -1,22 +1,18 @@
 {
-  sysLib,
   pkgs,
-  config,
+  lib,
   ...
 }: let
-  url_handler = sysLib.writeShellScript {
-    name = "url_handler";
-    src = ./url_handler.sh;
-    keepPath = true;
-    # Naming dependencies for this will be difficult, as it depend on overridden packages.
-    dependencies = with pkgs; [
-      rofi
-      libnotify
-      zathura
+  url_handler = pkgs.writeShellApplication {
+    name = "url-handler";
+    text = builtins.readFile ./url_handler.sh;
+    inheritPath = false;
+    runtimeInputs = [
+      pkgs.rofi
+      pkgs.libnotify
+      pkgs.zathura
+      pkgs.tskm
     ];
-    replacementStrings = {
-      ALL_PROJECTS_PIPE = "${config.soispha.taskwarrior.projects.projects_pipe}";
-    };
   };
 in {
   imports = [
@@ -39,10 +35,10 @@ in {
       };
     };
     desktopEntries = {
-      url_handler = {
-        name = "url_handler";
+      url-handler = {
+        name = "url-handler";
         genericName = "Web Browser";
-        exec = "${url_handler}/bin/url_handler %u";
+        exec = "${lib.getExe url_handler} %u";
         terminal = false;
         categories = [
           "Application"