about summary refs log tree commit diff stats
path: root/modules/by-name/nv/nvim/options/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/by-name/nv/nvim/options/default.nix (renamed from modules/home.legacy/conf/nvim/options/default.nix)12
1 files changed, 9 insertions, 3 deletions
diff --git a/modules/home.legacy/conf/nvim/options/default.nix b/modules/by-name/nv/nvim/options/default.nix
index f66b2181..72343b72 100644
--- a/modules/home.legacy/conf/nvim/options/default.nix
+++ b/modules/by-name/nv/nvim/options/default.nix
@@ -1,5 +1,11 @@
-{nixosConfig, ...}: {
-  programs.nixvim.opts = {
+{
+  config,
+  lib,
+  ...
+}: let
+  cfg = config.soispha.programs.nvim;
+in {
+  home-manager.users.soispha.programs.nixvim.opts = lib.mkIf cfg.enable {
     autoindent = true; # copy indent from previous line
     cindent = true; # use c like indenting rules
     breakindent = true; # continue indent visually
@@ -61,7 +67,7 @@
 
     # vim.opt.shada:append {'%'}; -- store buffers in the shada file and reopen them if nvim has been started without file name argument
 
-    shell = nixosConfig.users.users.soispha.shell.pname; # try to use default shell for the default user as a shell for ":!"
+    shell = "${cfg.shell}";
 
     spell = true; # activate spell checking
     spelllang = "en_us,de_de"; # set spell languages