about summary refs log tree commit diff stats
path: root/modules/by-name/fi/firefox/search_engines/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/by-name/fi/firefox/search_engines/default.nix')
-rw-r--r--modules/by-name/fi/firefox/search_engines/default.nix104
1 files changed, 104 insertions, 0 deletions
diff --git a/modules/by-name/fi/firefox/search_engines/default.nix b/modules/by-name/fi/firefox/search_engines/default.nix
new file mode 100644
index 00000000..d05a5af8
--- /dev/null
+++ b/modules/by-name/fi/firefox/search_engines/default.nix
@@ -0,0 +1,104 @@
+{pkgs, ...}: {
+  # DEFAULT
+  brave-search= {
+    name = "Brave Search";
+    urls = [{template = "https://search.brave.com/search?q={searchTerms}";}];
+    icon = ./logos/brave.svg;
+    definedAliases = ["@bs"];
+  };
+
+  # NIX
+  nix-packages= {
+    name = "Nix packages";
+    urls = [{template = "https://search.nixos.org/packages?type=packages&query={searchTerms}";}];
+    icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+    definedAliases = ["@np"];
+  };
+
+  nix-functions= {
+    name = "Nix functions";
+    urls = [{template = "https://noogle.dev/q?term={searchTerms}";}];
+    icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+    definedAliases = ["@ng"];
+  };
+
+  nixos-options= {
+    name = "NixOS options";
+    urls = [{template = "https://search.nixos.org/options?type=options&query={searchTerms}";}];
+    icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+    definedAliases = ["@no"];
+  };
+  homemanager-options= {
+    name = "Home-Manager options";
+    urls = [{template = "https://home-manager-options.extranix.com/?query={searchTerms}&release=master";}];
+    icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+    definedAliases = ["@nh"];
+  };
+
+  nixpkgs-issues= {
+    name = "Nixpkgs issues";
+    urls = [{template = "https://github.com/NixOS/nixpkgs/issues?q=is%3Aissue+is%3Aopen+{searchTerms}";}];
+    icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+    definedAliases = ["@ni"];
+  };
+  nixpkgs-pull-requests= {
+    name = "Nixpkgs pull requests";
+    urls = [{template = "https://github.com/NixOS/nixpkgs/pulls?q=is%3Apr+is%3Aopen+{searchTerms}";}];
+    icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+    definedAliases = ["@nr"];
+  };
+
+  nixpkgs-pull-requests-tracker= {
+    name = "Nixpkgs pull requests tracker";
+    urls = [{template = "https://nixpk.gs/pr-tracker.html?pr={searchTerms}";}];
+    icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+    definedAliases = ["@nt"];
+  };
+  nixos-wiki= {
+    name = "NixOS Wiki";
+    urls = [{template = "https://wiki.nixos.org/w/index.php?search={searchTerms}";}];
+    icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+    definedAliases = ["@nw"];
+  };
+
+  # RUST
+  rust-std= {
+    name = "Rust std";
+    urls = [{template = "https://doc.rust-lang.org/std/?search={searchTerms}";}];
+    icon = ./logos/rust_std.svg;
+    definedAliases = ["@rs"];
+  };
+  rust-tokio= {
+    name = "Rust tokio";
+    urls = [{template = "https://docs.rs/tokio/latest/tokio/index.html?search={searchTerms}";}];
+    icon = ./logos/rust_tokio.png;
+    definedAliases = ["@rt"];
+  };
+
+  # OTHER
+  google-scholar= {
+    name = "Google Scholar";
+    urls = [{template = "https://scholar.google.com/scholar?hl=en&q={searchTerms}";}];
+    icon = ./logos/google_scholar.ico;
+    definedAliases = ["@gs"];
+  };
+  wikipedia= {
+    name = "Wikipedia";
+    urls = [{template = "https://en.wikipedia.org/wiki/{searchTerms}";}];
+    icon = ./logos/wikipedia.svg;
+    definedAliases = ["@wp"];
+  };
+  arch-wiki= {
+    name = "Arch Wiki";
+    urls = [{template = "https://wiki.archlinux.org/index.php?search={searchTerms}";}];
+    icon = ./logos/arch_linux.svg;
+    definedAliases = ["@aw"];
+  };
+
+  "wikipedia".metaData.hidden = true;
+  "ddg".metaData.hidden = true;
+  "bing".metaData.hidden = true;
+  "google".metaData.hidden = true;
+  "Amazon.de".metaData.hidden = true;
+  "ebay".metaData.hidden = true;
+}