about summary refs log tree commit diff stats
path: root/hosts/desktop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/desktop/configuration.nix')
-rw-r--r--hosts/desktop/configuration.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/hosts/desktop/configuration.nix b/hosts/desktop/configuration.nix
new file mode 100644
index 00000000..2a3812cf
--- /dev/null
+++ b/hosts/desktop/configuration.nix
@@ -0,0 +1,21 @@
+# vim: ts=2
+{
+  config,
+  lib,
+  nixpkgs,
+  home-manager,
+  ...
+}: {
+  imports = [
+    ./hardware
+    ./networking.nix
+
+    ../../home-manager
+
+    ../../system
+
+    ../../services
+  ];
+
+  system.stateVersion = "23.05";
+}