about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/mail/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/soispha/config/mail/default.nix')
-rw-r--r--home-manager/soispha/config/mail/default.nix64
1 files changed, 0 insertions, 64 deletions
diff --git a/home-manager/soispha/config/mail/default.nix b/home-manager/soispha/config/mail/default.nix
deleted file mode 100644
index 475bcacf..00000000
--- a/home-manager/soispha/config/mail/default.nix
+++ /dev/null
@@ -1,64 +0,0 @@
-{
-  config,
-  pkgs,
-  lib,
-  ...
-}: let
-  non_public_accounts = import ./non_public_accounts.nix {inherit pkgs;};
-  accounts = lib.recursiveUpdate {inherit soispha;} non_public_accounts;
-
-  soispha = {
-    address = "soispha@vhack.eu";
-    userName = "soispha@vhack.eu";
-    realName = "Soispha";
-    primary = true;
-    passwordCommand = "${pkgs.libsecret}/bin/secret-tool lookup account soispha@vhack.eu";
-    aliases = [
-      "admin@vhack.eu"
-    ];
-    folders = {
-    };
-    gpg = {
-      encryptByDefault = true;
-      key = "9606FC749FCE16360723D4ADA5E94010C3A642AD";
-      signByDefault = true;
-    };
-    signature = {
-      # TODO:
-    };
-    neomutt = {
-      enable = true;
-    };
-    mbsync = {
-      enable = true;
-      create = "both";
-    };
-    himalaya = {
-      enable = true;
-      backend = "imap";
-      sender = "smtp";
-      settings = {
-        # TODO:
-      };
-    };
-    smtp = {
-      host = "server1.vhack.eu";
-      port = 465;
-    };
-    imap = {
-      host = "server1.vhack.eu";
-      port = 993;
-    };
-    jmap = {
-      # TODO:
-    };
-    maildir = {
-      path = "soispha";
-    };
-  };
-in {
-  accounts.email = {
-    maildirBasePath = "${config.xdg.dataHome}/maildir";
-    inherit accounts;
-  };
-}