about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/pkgs/scripts.nix')
-rw-r--r--hm/soispha/pkgs/scripts.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index d1a78c29..0b32a9c1 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -193,6 +193,22 @@
     path = "wrappers";
     dependencies = builtins.attrValues {inherit (pkgs) libvirt;};
   };
+  ytc-scr = write_script {
+    name = "ytc";
+    path = "wrappers";
+    dependencies = builtins.attrValues {
+      inherit
+        (pkgs)
+        jq
+        yt-dlp
+        ytcc
+        csvtool
+        mpv
+        ffmpeg
+        gnused
+        ;
+    };
+  };
   yti-scr = write_script {
     name = "yti";
     path = "wrappers";
@@ -214,5 +230,6 @@ in [
   spodi-scr
   update-sys-scr
   virsh-del-scr
+  ytc-scr
   yti-scr
 ]