about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/pkgs/scripts.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index 57aff326..a1603656 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -14,7 +14,7 @@
   }:
     sysLib.writeShellScript {
       inherit name keepPath;
-      src = ./scripts/${path}/${name};
+      src = ./scripts/${path}/${name}.sh;
       dependencies = dependencies ++ [pkgs.dash];
       generateCompletions = completions;
     };
@@ -25,7 +25,7 @@
     dependencies_python ? _: [],
     keepPath ? false,
   }: let
-    src = ./scripts/${path}/${name};
+    src = ./scripts/${path}/${name}.py;
     dependencies =
       [(pkgs.python3.withPackages dependencies_python)]
       ++ dependencies_system;
@@ -53,7 +53,7 @@
 
   con2pdf-scr = sysLib.writeShellScript {
     name = "con2pdf";
-    src = ./scripts/apps/con2pdf;
+    src = ./scripts/apps/con2pdf.sh;
     dependencies = builtins.attrValues {inherit (pkgs) sane-backends imagemagick coreutils fd;};
     generateCompletions = true;
     replacementStrings = {
@@ -113,7 +113,7 @@
 
   ll-scr = sysLib.writeShellScript {
     name = "ll";
-    src = ./scripts/wrappers/ll;
+    src = ./scripts/wrappers/ll.sh;
     wrap = false;
   };