about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/pkgs/scripts.nix16
1 files changed, 15 insertions, 1 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index c4d284c1..a8568d43 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -137,6 +137,19 @@
   #     path = "wrappers";
   #     dependencies = builtins.attrValues {inherit (pkgs) lf ueberzug;};
   #   };
+  lyrics-src = write_script {
+    name = "lyrics";
+    path = "wrappers";
+    dependencies = builtins.attrValues {
+      inherit
+        (pkgs)
+        mediainfo
+        mpc-cli
+        jq
+        gnused
+        ;
+    };
+  };
   spodi-scr = write_script {
     name = "spodi";
     path = "wrappers";
@@ -155,14 +168,15 @@
 in [
   aumo-scr
   con2pdf-scr
+  fupdate-src
   ll-scr
   # llp-scr # TODO: see above
+  lyrics-src
   neorg-scr
   screenshot_persistent-scr
   screenshot_temporary-scr
   spodi-scr
   update-sys-scr
-  fupdate-src
   virsh-del-scr
   yti-scr
 ]