about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/pkgs/scripts.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index e295a587..c801b3f0 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -107,6 +107,25 @@
     path = "small_functions";
     dependencies = builtins.attrValues {inherit (pkgs) git git-crypt nixos-rebuild sudo openssh coreutils mktemp gnugrep gnused;};
   };
+  fupdate-src = write_script {
+    name = "fupdate";
+    path = "apps";
+    dependencies = builtins.attrValues {
+      inherit
+        (pkgs)
+        dash
+        nix
+        gnugrep
+        fd
+        coreutils
+        bat # used by batgrep
+        gnused # required by batgrep
+        git # needed to fetch through git
+        git-crypt # needed to unlock git-crypted repos
+        ;
+      inherit (pkgs.bat-extras) batgrep;
+    };
+  };
   ll-scr = sysLib.writeShellScriptWithLibraryUnwrapped {
     name = "ll";
     src = ./scripts/wrappers/ll;
@@ -142,6 +161,7 @@ in [
   screenshot_temporary-scr
   # spodi-scr # # TODO: Reactivate when spotdl builds again <2023-10-31>
   update-sys-scr
+  fupdate-src
   virsh-del-scr
   yti-scr
 ]